re = /(?:^Rake \(([0-9]+)\) Pot \(([0-9]+)\) Players \(|)(\w+):?\s*(\d+)(?=[^()]*\))/m
str = 'Rake (100) Pot (1000) Players (andy: 10, bob: 20, cindy: 70)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result