package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.cf\.\s*(.*?)-`)
var str = `originations-ao-accounts-gb-hbeu-v0-1-4.cf.wgdc-drn-100.cloud.uk.hsbc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}