$re = '/\.cf\.\s*(.*?)-/';
$str = 'originations-ao-accounts-gb-hbeu-v0-1-4.cf.wgdc-drn-100.cloud.uk.hsbc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);