// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.cf\.\s*(.*?)-").unwrap();
let string = "originations-ao-accounts-gb-hbeu-v0-1-4.cf.wgdc-drn-100.cloud.uk.hsbc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}