using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9(\(\)\-\+\s\.]+?[0-9{1,10}]+[\s?\-?\.?\,]+?$";
string input = @"+ - .2555555555.(5555 -
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}