package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9(\(\)\-\+\s\.]+?[0-9{1,10}]+[\s?\-?\.?\,]+?$`)
var str = `+ - .2555555555.(5555 -
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}