re = /^[0-9(\(\)\-\+\s\.]+?[0-9{1,10}]+[\s?\-?\.?\,]+?$/
str = '+ - .2555555555.(5555 -
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end