import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<p>SOME\\s)(TEXT\\s?.*?)(?:<\\/p>)";
final String string = "<p>SOME TEXT</p> \n"
+ "<p>SOME TEXT (dynamic content 1)</p> \n"
+ "<p>SOME TEXT (dynamic content 2)</p> \n"
+ "<p>SOME TEXT</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}