const regex = /(?:<p>SOME\s)(TEXT\s?.*?)(?:<\/p>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<p>SOME\\s)(TEXT\\s?.*?)(?:<\\\/p>)', 'g')
const str = `<p>SOME TEXT</p>
<p>SOME TEXT (dynamic content 1)</p>
<p>SOME TEXT (dynamic content 2)</p>
<p>SOME TEXT</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}