re = /(?:<p>SOME\s)(TEXT\s?.*?)(?:<\/p>)/
str = '<p>SOME TEXT</p>
<p>SOME TEXT (dynamic content 1)</p>
<p>SOME TEXT (dynamic content 2)</p>
<p>SOME TEXT</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end