using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z][a-z0-9]*(?:_[a-z0-9]+)*(?:(?<![0-9]),[a-z][a-z0-9]*(?:_[a-z0-9]+)*)*$(?<![0-9])";
string input = @"a
abc
abc_abc
abc_d_e,abc_def
a,b,d
a12a_a
a12a_a,a12431a_a
a1_b
word1_2_word
word_2k
word_2
a,1
1,3
a,b,_
1_2
a123,aaa
a12a_a,1a
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}