use strict;
my $str = 'a
abc
abc_abc
abc_d_e,abc_def
a,b,d
a12a_a
a12a_a,a12431a_a
a1_b
word1_2_word
word_2k
word_2
a,1
1,3
a,b,_
1_2
a123,aaa
a12a_a,1a
';
my $regex = qr/^[a-z][a-z0-9]*(?:_[a-z0-9]+)*(?:(?<![0-9]),[a-z][a-z0-9]*(?:_[a-z0-9]+)*)*$(?<![0-9])/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}