re = /\s*\[\s*\[\s*\[\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*,\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*\]\s*,\s*\[\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*,\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*\]\s*,\s*\[\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*,\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*\]\s*\]\s*\]\s*/m
str = '[[[5,3],[2,8],[6,-3]]]
[ [ [ 5.23 , 3.42 ] , [ 2. , 8.17 ] , [ 6 , -3 ] ] ]
[[
[ 5, 3],
[ 2, 8.43],
[ -6.18,-3]
]]
[
[
[
5,
3.141592653
],
[
2.718281828,
8
],
[ 0.618,
-35.16e-17
]
]
]
'
subst = '{"\\1,\\4","\\7,\\10","\\13,\\16"}\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result