using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+(?: \([^\)]*\))?)";
string input = @"foo (foo, foofoo), bar (foobar), foo, bar (barbar, foo), bar, foo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}