package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+(?: \([^\)]*\))?)`)
var str = `foo (foo, foofoo), bar (foobar), foo, bar (barbar, foo), bar, foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}