#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\([\w\s]*\(*[\w\s]*[()]*[\w\s]*\)\)"
Local $sString = "Example(123) (Example (123))" & @CRLF & _
"" & @CRLF & _
"Hello World (Hello World (123))" & @CRLF & _
"" & @CRLF & _
"any_string_abc (anything) (any_string (whatever)(whatever123))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")