$re = '/\([\w\s]*\(*[\w\s]*[()]*[\w\s]*\)\)/';
$str = 'Example(123) (Example (123))
Hello World (Hello World (123))
any_string_abc (anything) (any_string (whatever)(whatever123))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);