import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([\\w\\s]*\\(*[\\w\\s]*[()]*[\\w\\s]*\\)\\)";
final String string = "Example(123) (Example (123))\n\n"
+ "Hello World (Hello World (123))\n\n"
+ "any_string_abc (anything) (any_string (whatever)(whatever123))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}