package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`3[7-9]|[4-9]\d+|\d{3,}`)
var str = `Items 1 to 36 of 605 total
Items 1 to 36 of 117 total
Items 1 to 36 of 74 total
37
38
39`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}