import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "3[7-9]|[4-9]\\d+|\\d{3,}";
final String string = "Items 1 to 36 of 605 total\n"
+ "Items 1 to 36 of 117 total\n"
+ "Items 1 to 36 of 74 total\n\n"
+ "37\n"
+ "38\n"
+ "39";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}