use strict;
my $str = 'Items 1 to 36 of 605 total
Items 1 to 36 of 117 total
Items 1 to 36 of 74 total
37
38
39';
my $regex = qr/3[7-9]|[4-9]\d+|\d{3,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}