using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[#@](?![\s\S]*[#@])";
string input = @"@foo #foo@foo@foo #foo
foofoofoo
foo @bar";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}