$re = '/[#@](?![\s\S]*[#@])/';
$str = '@foo #foo@foo@foo #foo
foofoofoo
foo @bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);