using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A\d?[a-zA-Z]{1,2}\d{1,4}[a-zA-Z]{1,3}\Z";
string input = @"AE0MW";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}