import Foundation
let pattern = #"\A\d?[a-zA-Z]{1,2}\d{1,4}[a-zA-Z]{1,3}\Z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"AE0MW"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}