$re = '/^#([a-zA-Z0-9 ]*) : ([a-zA-Z0-9 ]*)$/';
$str = '#Property Name : Property Value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);