re = /^#([a-zA-Z0-9 ]*) : ([a-zA-Z0-9 ]*)$/
str = '#Property Name : Property Value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end