package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http|https):\/\/[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}'.'((:[0-9]{1,5})?\/.*)?$`)
var str = `https://creativecommons.org/licenses/by-nc-sa/4.0/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}