re = /^(http|https):\/\/[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}'.'((:[0-9]{1,5})?\/.*)?$/m
str = 'https://creativecommons.org/licenses/by-nc-sa/4.0/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end