$re = '/^(http|https):\/\/[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}\'.\'((:[0-9]{1,5})?\/.*)?$/m';
$str = 'https://creativecommons.org/licenses/by-nc-sa/4.0/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);