package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(http|https)?(:\/\/)?(\S*)\.(\w{2,4}(\S*))\b`)
var str = `I'm at Harrah's Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}