re = /\b(http|https)?(:\/\/)?(\S*)\.(\w{2,4}(\S*))\b/m
str = 'I\'m at Harrah\'s Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end