$re = '/\b(http|https)?(:\/\/)?(\S*)\.(\w{2,4}(\S*))\b/m';
$str = 'I\'m at Harrah\'s Hotel and Casino: Luxury Suite (New Orleans, LA) w/ 2 others http://t.co/UjxTIdiJ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);