$re = '/(?:^|(?<=\W))\d+(?=\W|$)/';
$str = '850 7th Ave Frnt 1, New York, NY 10019 ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;