re = /(?:^|(?<=\W))\d+(?=\W|$)/
str = '850 7th Ave Frnt 1, New York, NY 10019 '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result