import Foundation
let pattern = #"(?:^|(?<=\W))\d+(?=\W|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"850 7th Ave Frnt 1, New York, NY 10019 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)