package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).*[\?&]si=(\d+)`)
var str = `http://www.example.me/area/?bb=4894&si=4077765&f=fjjjf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}