$re = '/.*[\?&]si=(\d+)/i';
$str = 'http://www.example.me/area/?bb=4894&si=4077765&f=fjjjf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);