re = /.*[\?&]si=(\d+)/i
str = 'http://www.example.me/area/?bb=4894&si=4077765&f=fjjjf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end