#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\s+(\d{1,2}:\d{1,2} [AP]M)$"
Local $sString = "Agent AB 7:00 AM" & @CRLF & _
"Agent AB 7:00 AM" & @CRLF & _
"Cust XY 8:00 AM" & @CRLF & _
"Cust XY 9:00 AM" & @CRLF & _
"Agent AB 11:00 AM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")