re = /^(.*?)\s+(\d{1,2}:\d{1,2} [AP]M)$/m
str = 'Agent AB 7:00 AM
Agent AB 7:00 AM
Cust XY 8:00 AM
Cust XY 9:00 AM
Agent AB 11:00 AM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end