package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\s+(\d{1,2}:\d{1,2} [AP]M)$`)
var str = `Agent AB 7:00 AM
Agent AB 7:00 AM
Cust XY 8:00 AM
Cust XY 9:00 AM
Agent AB 11:00 AM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}