import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\{(?:[$@#]).*(?:[$@#])\\}$).*";
final String string = "Free text which is fine\n"
+ "{#some other text#}\n"
+ "Text with numbers 671\n"
+ "{@Hello world@}\n"
+ "{$Hello Mars$}\n"
+ "{$some text which i do not close\n"
+ "{$Hello Mars$} how are you?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}