re = /^(?!\{(?:[$@#]).*(?:[$@#])\}$).*/m
str = 'Free text which is fine
{#some other text#}
Text with numbers 671
{@Hello world@}
{$Hello Mars$}
{$some text which i do not close
{$Hello Mars$} how are you?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end