$re = '/^(?!\{(?:[$@#]).*(?:[$@#])\}$).*/m';
$str = 'Free text which is fine
{#some other text#}
Text with numbers 671
{@Hello world@}
{$Hello Mars$}
{$some text which i do not close
{$Hello Mars$} how are you?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);