package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[.*?\]|([^[]+)`)
var str = `here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}