re = /\[.*?\]|([^[]+)/
str = 'here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end