$re = '/\[.*?\]|([^[]+)/';
$str = 'here is some text [anything123][/21something] and here is too [sometext][/afewtext] and here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);