import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\w+\\.(?!keys))*(?:\\w+))\\.keys\\(\\)";
final String string = "assignment_progress_header = ','.join(self.ASSIGNMENT_PROGRESS_STRUCTURE.keys()) + '\\n'\n"
+ "j.keys()\n"
+ "adasd.keys()\n"
+ "snallg = pop.keys()\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}