$re = '/((?:\w+\.(?!keys))*(?:\w+))\.keys\(\)/';
$str = 'assignment_progress_header = \',\'.join(self.ASSIGNMENT_PROGRESS_STRUCTURE.keys()) + \'\\n\'
j.keys()
adasd.keys()
snallg = pop.keys()
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);